Introduction to Geographic Information Systems and ArcGIS for Spatial Analysis

Stacey Maples – GIS Specialist & Instruction Coordinator at the Sterling Memorial Library Map Department - stacey.maples@yale.edu

This introductory session will focus upon the fundamental concepts and skills needed to begin using Geographic Information Systems software for the exploration and analysis of spatial data in ArcGIS. Topics will include: What is GIS? Spatial Data Models and Formats; Projections and Coordinate Systems; Basic Data Management; The ArcMap User Interface; and Simple Analysis using Visualization.

GIS Resources:
www.library.yale.edu/maps Yale Map Dept. Website
http://mailman.yale.edu/mailman/listinfo/gis-l Yale GIS Listserv
http://guides.library.yale.edu/GIS Yale GIS Support Portal

Download Tutorial Data from the GIS LibGuide
1. http://guides.library.yale.edu/gis ; Yale GIS Workshops Tab
2. Download the Dataset for the Introduction to Geographic Information Systems and ArcGIS for Spatial Analysis Workshop (Right-click; Save Target As; Save to c:\temp)

Extract the Data to the c:\Temp folder
1. Browse to the c:\Temp folder, where you saved the Data
2. Right-click on the EX01_World.zip and select Extract All...
3. Accept all defaults to extract the data file to C:\Temp
Open ArcMap and Explore the User Interface

ArcMap is the 2D mapping component of the ArcGIS Suite of software. Most of your basic data management and analysis will be done in using ArcMap. The first thing we want to do is **Open ArcMap** and get familiar with the Default User Interface.

1. In Windows, go to the Programs menu and find the ArcGIS Program Group, then select ArcMap to Open ArcMap.
2. You should be presented with the **New Document** dialog window, with the **Blank Map** template selected by default. Simply click OK to accept this template.

You should then be presented with something like the interface you see below:
The Basic Components of the ArcMap Interface
The ArcMap interface is made up of three basic components:

**The Data Frame** – The Data Frame is where your geographic datasets will be visualized

**Tabbed Windows:**

- **The Table of Contents** – The Table of Contents is the most important of the “Tabbed Windows” set, and is visible by default. This window is where you will interact with your data most of the time. As you add geographic and non-geographic datasets to your Map Document, they will show up in the Table of Contents as Layers. Much of your work in ArcMap will be initiated by right-clicking on one or more of the Layers in the Table of Contents.

- **Search Window** – The Search Window shows up, by default, as a Tabbed Window. This window is used to search for ArcToolbox Tools, Map Documents and Data (provided you have enabled indexing for your data folders, which will be covered in a later lab).

- **Catalog Window** – The Catalog Window functions much as Explorer does in Windows. In this window, you can create connections to drives, folders and network resources for use in ArcGIS. Many of the tasks related to data maintenance (creating empty shapefiles/feature classes, new Geodatabases, etc...) are performed using the Catalog Window. This window acts as a ‘lite’ version of the more fully featured ArcCatalog component of the ArcGIS Suite.

- **Tables, Imagery Analysis Window, etc...** - There are a few other windows that can be ‘Tabbed’ in ArcMap. We will cover these as needed in the tutorials.

**Toolbars** – There are literally dozens of Toolbars in ArcMap. Each of these toolbars is composed of a set of buttons that launch tools that are related to a GIS task of some sort. For example, the oh-so creatively named **“Tools” Toolbar** is composed of the most often used tools for navigating in the Data Frame and basic selection and querying of data layers. Toolbars can be enabled in several ways, but the easiest is to simply right-click in an empty area of the toolbar part of ArcMap and select the toolbar you need.

**Interacting with Tabbed Windows**

1. Move your cursor over the **Catalog Tab**, just to the right side of the Data Frame. Note that the Catalog Window expands.
2. Click on the **Auto Hide Pushpin Icon** at the top of the Catalog Window to ‘pin’ the window open.
3. Now, move your cursor over the Search Tab to expand the Search Window.
4. Click on the Auto Hide Pushpin Icon at the top of the Search Window to ‘pin’ the window open.
5. Using the Search Window’s Title Bar, Click and Drag the Search Window away from it’s docked position. Note the ‘Docking Arrows’ that appear as you move the window.
6. Drag the Search Window around to each of the Docking Arrows and note the effect on the blue Docking Preview rectangle.
7. Finally, drop the Search Window on the bottom Docking Arrow of the “Flower” that appears when you drag it over the Catalog Window.

Let’s open a Map Document!

You should, in addition to a Data Folder full of shapefiles, have a Map Document in your $\text{C:}\text{\Temp}\text{EX01_\_World}$ Folder called… EX01_\_World.mxd. The extension is hidden in Catalog, but the icon looks like this: 

1. Drag the EX01_\_World Map Document into the Data Frame of ArcMap to open it.

Take a look at the Change to the Top Level “Home” Folder in Catalog. It has changed from the Application Default, to the Folder when the Map Document you are working with is stored. Handy, eh!? 
The Data Frame and its Properties

Now take a look at the Table of Contents. You should see a “Layers” item, followed by 3 Layers corresponding to the shapefiles in your Data Folder. The “Layers” item at the top of the TOC represents the Data Frame, within which all of your layers are contained. What you don’t see is that DBF Table, although it is actually included in the Map Document, too. This is because you are currently looking at the “List by Drawing Order” view of the TOC. Since the Table doesn’t have an explicit geographic component (it’s just a table of data), it isn’t shown in this view.

1. Click on the List By Source button (the second button from the left at the top of the TOC).

Note that the World_Population_2007 table is now listed at the bottom of the TOC. Note, also, that the layers are organized underneath the path at which they are located. If this Map Document contained links to datasets in other locations, they would be listed under that path or network address.

Projections and Coordinate Systems in ArcMap

The datasets in this Map Document are all in the same Projection/Geographic Coordinate System, though it is not the one being used to display the data in the Data Frame, currently. In ArcMap, datasets can (and in most cases, must) have their own explicitly defined Projection/Coordinate Systems, while the Data Frame can have a completely different Projection/Coordinate System. This allows you to add geographic datasets with different Projection/Coordinate Systems to ArcMap, by treating the Data Frame’s Projection/Coordinate System as the Map Document’s Lingua Franca, projecting (on the fly) all of the datasets to the Data Frame Projection. While this may seem convenient, it comes at a cost: Map Documents that make use of this type of on-the-fly projection render the data in the Data Frame at a much slower rate than those in which the datasets and the Data Frame all share the same
Projection/Coordinate Systems. Additionally, disparate Projection/Coordinate Systems can cause major issues and errors when analyzing across layers such as in geoprocessing that requires overlay and transfer of attributes across layers. For this reason, it is best to select a Projection/Coordinate System that is suitable for your particular analysis and geographic scale, and project all of your data to the same.

**Change Coordinate System to GCS WGS 1984**

1. Right-click on the Layers Item at the top of the Table of Contents and select **Properties**...
2. Click on the Coordinate system Tab and expand the Layers Folder in the “Select a Coordinate System:” panel.
3. Expand the Cities Folder and select the GCS_WGS_1984 Projection file. Click OK.

What you have just done is reassigned the coordinate system of the Data Frame to that of the Cities Layer in your Map Document. This (GCS WGS 1984) is actually the coordinate system of all of the layers in your Map Document, so you should experience an increase in drawing performance, since ArcMap is no longer projecting these layers on-the-fly to the World from Space projection (which was chosen for its extremity, in this case). The result of this change should be a fairly substantial change to the view on the Data Frame.
Explore Navigations Tools and Visibility in Data Frames

Before we begin to explore the properties of individual layers in the Map Document, we will first spend some time getting familiar with the navigation tools in ArcMap. Most of these tools can be found on the “Tools” toolbar, though some of the more useful ones involve right-click context menus of the layers.

**Zoom to Layer**

1. Right-click on the Lat_Lon_30 Layer, in the TOC, and select Zoom to Layer.

Note that this should present you with the entirety of the Lat_Lon_30 Layer’s extent.

**Tools Toolbar Navigation**

The Tools Toolbar provides the bulk of the tools for navigation in the Data Frame. Most of them are fairly obvious. Take a moment to explore each of these tools, and how it works.

1. The Zoom Tool works exactly as you would expect. Click on the Zoom Tool, and drag a box to enclose the Continental United States. You can also single-click with this tool to use it as a Fixed Zoom Tool.
2. The Zoom Out Tool isn’t quite as intuitive as the Zoom Tool. Click on the Zoom Out Tool and Drag a Box over the State of Texas. ArcMap will fit the current extent of the Data Frame into the box you just defined. You can also single-click with this tool to use it as a Fixed Zoom Tool.
3. The Pan Tool changes the Extent of your Data Frame, without changing the scale. Click on the Pan Tool and use it to move around the Data Frame.
4. The Full Extent Button zooms you to the full extent of the layer in your Map Document with the largest spatial extent. This can sometimes be problematic if you are working at a local level, but using one or more layers that are global in extent (for example, many of the network basemap services).
5. The Fixed Zoom In Tool works as expected. Click on the Fixed Zoom In Tool and take a look at the Scale Dropdown on the Standard Toolbar and note that the Fixed Zoom In Tool is tied to the Scale Values in this dropdown.
6. The Fixed Zoom Out Tool works as expected. Click on the Fixed Zoom Out Tool and take a look at the Scale Dropdown on the Standard
7. The Back Button works much like its analogous tool in your browser, allowing you to step back through previous changes in Scale/Extent. This tool is particularly useful if you change your Data Frame Extent inadvertently.

8. Again, the Forward Tool is analogous to the browser forward button, stepping forward through the Scale/Extents in your project history.

**Bookmarks**

One of the most useful navigation tools is the ability to create spatial Bookmarks.

1. Using the Zoom Tools on the Tools Toolbar, Zoom your Data Frame view to the European/Asian Landmass.
2. On the Main Menu, go to Bookmarks>Create…
3. Name your “Bookmark Europe & Asia” and click OK.
4. Click on the Full Extent Button.
5. Return to Main Menu>Bookmarks and select your Europe & Asia bookmark.

These can even be easily shared or moved from one Map Document to another, too. Returning to the Bookmarks Menu item, you will find a Manage… option, which opens the Bookmark Manager. This manager provided option for reordering, deleting, creating and saving your bookmarks, or selected subsets. Bookmarks are saved as .dat files that can be loaded in other Map Documents.

**Display Order**

The order of display in your Data Frame is determined by the Layer Order in the Table of Contents, when it is in the Display Order Mode.

1. If you haven’t already, change your Table of Contents view from “List by Source” to “List by Drawing Order” using the View Buttons at
the top of the Table of Contents.

2. Click and Drag the Lat_Lon_30 layer to the top of the Table of Contents. Note that the other layers in your Map Document are now obscured.

Working with Layers & Their Properties

Layer Visibility
The Table of Contents also controls Layer Visibility. You can toggle the Layer Visibility using the checkbox next to each Layer in the Table of Contents.

1. Use the Visibility Checkbox next to the Lat_Long_30 Layer to turn off the visibility of the layer and reveal the other layers again.

Examining and Selecting by Attributes
The most basic method of analysis in GIS is selection and subsetting of data by attribute values. Now that the Cities Layer is visible again, we can begin to address the fact that this layer is a bit overpopulated for our purposes. Let’s say we are interested in visualizing the global distribution of cities with populations greater than or equal to 1 million. First we need to see if the data necessary to do this exists in our dataset.

1. Right-Click on the Cities Layer and select “Open Attribute Table” to open the Attribute Table of the layer.
2. Click and Drag the resulting Table Window to the Docking Arrow at the bottom of the Data Frame so that it spans the entire width of the ArcMap Application Window.
3. Scroll to the right until you can see the POP, POP_RANK and POP_CLASS Attribute Fields
4. Right-click on the POP Field Header and select Sort Descending.
5. Scroll down through the Attribute table to examine the relationship between these three variables.
Selecting By Attributes

What we would like to do is select all of the cities in this dataset that have a population of 1 million or greater. This can be accomplished using any one of these three of these variables, but we will use the POP_RANK variable for the sake of simplicity.

1. On the Upper left corner of the Attribute Table, find the Select by Attributes button and click on it.
2. Leave the Method: “Create a new selection”
3. Scroll through the list of Attribute Fields and Double-click on the “POP_RANK” value to place it into the SELECT Argument textbox, at the bottom of the window.
4. Click on the “<=” Button to enter the operator into the SELECT Argument.
5. With the “POP_RANK” value still highlighted in the Field List, click on the Get Unique Values button and double-click on 2 to complete the SELECT argument.

Note that you could also simply type any of the components of the SELECT argument, manually, using SQL syntax.

6. Click Apply and Close to apply the selection to your Cities Layer.
7. Scroll through the Attribute Table and note the records that are selected.
8. Unpin or close the Attribute Table so that you can observe that the selection from the Attribute Table is also reflected in the Data Frame.

Exporting Data

Notice that the Selection looks more manageable than the full dataset. Now you will export this selection as a new shapefile, and bring it back into ArcMap as a new Layer. As you do this, you will take advantage of a sort of “universal” in ArcMap. Anytime you have selected a subset of one of your data layers ArcMap will only act on that subset while it is active. This means that Geoprocessing, attribute calculations, data exports, etc... act as if the active selection is the whole of the dataset. This can come in quite handy.
1. Right-click on the Cities Layer in the Table of Contents and select Data>Export Data…
2. Note that the Export: Default is Selected Features
3. Click on the Browse Button for the Output feature class.
4. Click on the Home Button and Browse into the Data Folder to save the Output Feature Class as C:\temp\EX01_World\Data\Major_Cities.shp
5. Click Save and OK to Export the Selected Subset.
6. Click Yes when prompted to add the exported data as a layer in ArcMap.
7. Right-click on the original Cities Layer and select Remove.

**Change City Symbology**

Now we have two classes of POP_RANK to work with, and would like to distinguish them from one another, visually.

1. Right-Click on the new Major_Cities Layer and Open it’s Properties
2. Click on the Symbology Tab and Select Categories in the Show Options panel.
3. Change the Value Field to POP_CLASS and click on the Add All Values button.
4. Uncheck the <all other values> item and double click on symbol to the left of the “1,000,000 to 4,999,999” item.
5. In the resulting Symbol Selector, select Circle 1 and change its size to 4 points. Click OK.
6. Using the same method, change the symbol for the “5,000,000 and greater” item to Circle 1 with a size of 10 points.

7. Click OK to close the Properties Window and commit the changes to symbology.

**Label Cities**

Another property of the layers in our Map Document that we might want to enable is the labeling of features. This can be accomplished, based upon an attribute value for each of the features. In many cases, this might be the name, or some other identifying attribute of the feature, but in some cases it might be a quantitative value associated with the features. It is even possible to use VB Scripting to assemble labels from several attributes and text elements. In this example, we will label only the cities with a POP_RANK value of 1.

1. Right-Click on the Major_Cities Layer and select Label Features.

Note that this turns on labels for all features and, by ArcMap selects a field containing names, by default. Because there are so many visible features in this layer, this creates an unreadable labeling scheme. To remedy this, we will limit labeling to the largest cities in the Major Cities Layer.

2. Right-click on the Major_Cities Layer and select Properties. Click on the Labels Tab.

3. Change the Method to “Define classes of features and label each class differently”

4. Click on the SQL Query… button.

5. In the SQL Query window, create a SELECT argument as follows:
   “POP_RANK”=1

6. Click OK twice to apply this labeling scheme to the Data Frame.
Join a Table to a Layer

Now we will turn our attention to the World_Countries Layer. Ultimately, we would like to visualize the layer based upon population density. However, the attribute table for this layer doesn’t contain data on population. Fortunately we have a table in our Map Document with the necessary population attribute.

1. Change the Table of Contents to the List by Source view so that the World_Population_2007 Table is visible.
2. Right-click on the World_Population_2007 Table and select Open.
3. Scroll through the attributes and note the FIPS_CNTRY Attribute Field. Close the table.
4. Open the Attribute Table for the World_Countries Layer and note that it also has a FIPS_CNTRY Attribute Field.

Since this attribute exists in both of these attribute tables, and its values are identical across the two datasets, we can use this attribute as the “Key Field” for our table join.

5. Close the Attribute Table for the World_Countries Layer.
6. Right Click on the World_Countries Layer and Select Joins and Relates>Join…
7. Select FIPS_CNTRY as the Join Field for the World_Countries Layer.
8. If it is not selected automatically, select World_Population_2007 as the Table to join to the World_Countries Layer, and FIPS_CNTRY as the Join Field for this table.
9. Click OK to create the Join.
10. Open the Attribute Table for the World_Countries Layer and note the POP2007 Attribute (along with all other attributes from the World_Population_2007 table).
**Definition Querys**

You may have noticed that many of the features in the World_Countries Layer had values of -99999 for the POP2007 attribute. This normally indicates NODATA for the particular feature. In this case, we would like to exclude these values from our Map Document. We could, of course, use the method used to subset the Cities layer earlier in the tutorial, but this time we will use another method called Definition Query.

Definition Queries “define” a dataset, based upon a SQL Query, like the ones we have used to create the selection by attributes and the labeling class. In this case, the Definition Query “defines” a subset of the data layer which ArcMap treats as the entirety of the dataset. It does not, however, require creating a new dataset (preventing redundancy in data storage) and does not alter the dataset being referenced, only our view of it in ArcMap.

1. Right-click the World_Countries Layer and open its Properties.
2. Click on the Definition Query Tab.
3. Click on the Query Builder Button and create a SELECT Argument as follows: 
4. Click OK Twice to apply the Definition Query.
5. Open the Attribute Table for the World_Countries Layer and note that the POP2007 Field no longer contains records with -99999 as a value.

Because most of the features with this value are lesser countries (in terms of area) it may not be apparent that the corresponding geographic features have also been removed from the Layer, as well.

**Symbolize Countries by Population Density**

We can now use the POP2007 attribute to visualize population density. Even though the POP2007 variable is a raw counts variable, we can use the Symbology Tabs Normalization capability to divide the POP2007 variable by the area of the features to create the density value on-the-fly.

1. Open the Properties for the World_Countries Layer and click on the Symbology Tab.
2. Select Quantities and set the Value to the POP2007 variable.
3. Set the Normalization Field to the SQMI field.
4. Click on the Classify... Button and set the Classification Method to Quantiles. Click OK.
5. Select a Color Ramp and Click OK to apply the Symbology.

**Adding “Cloud” Data**

Often, you will want to provide a cartographic basemap for your data in order to give it geographic context. Cartographic design can be quite time consuming. Fortunately, ArcMap leverages “Cloud” technologies to make a wide variety of pre-designed cartographic basemap layer available over the internet for use in your Map document.

1. On the Main Menu, go to File>Add Data>Add Basemap.
2. In the resulting window, select the “Physical” basemap, and click Add.
3. Wait for the basemap to render and save your work.

**Exporting Your Map**

1. Save your Work.
2. On the Main Menu, go to File>Export Map...
3. Click on the Home Button to browse to the C:\Temp\EX01_World\ Folder.
4. Change the Save as type to PNG(*.png)
5. Change the Resolution to 200 dpi
6. Check the option to “Clip Output to Graphics Extent”
7. Click Save.
8. Browse to the C:\Temp\EX01_World\ Folder and double click on the EX01_World.png file to view it in the default image viewer.