Yale University Center for Science and Social Science Information

home | schedules | who we are | about | YUL | ITS

<  October 2016 >
(Leap Year)
Su Mo Tu We Th Fr Sa

Reserve the classrooms

Schedule for 10/24/2016

Stat Consultants
CSSSI (219 Prospect St)
Consultants Schedule on the CSSSI website.
CSSSI KBT Classroom on schedule.yale.edu website.
CSSSI Rosenkranz Classroom on schedule.yale.edu website.


MapInfo is a GIS (Geographical Information Systems) software available on the StatLab NT network.

To Start MapInfo
Click the MapInfo Icon in the Windows Applications group.

Opening, Importing, and Registering maps in MapInfo
  • File>Open Table... or opens an existing MapInfo table (extension .TAB), ASCII data, spreadsheet data, or a raster image. (use the "List Files of Type" option in the Open Table dialog box to select).
  • Table>Import... imports files of other selected formats (.MIF, .MBI, .DXF, ...)
  • Registering a raster image to give it geographical coordinates is a little more complex:
    • If you have not already opened the (registered) map with which you would like to register the raster image, load it into a window.
    • Use File>Open Table... and choose 'Raster Image' under "List Files of Type"
    • Choose "Register" in the ensuing dialog box.
    • The Image Registration box which follows allows you to match points on the raster image with points on the map containing latitude and longitude data. In order to do this, do:
      • click on a point in the raster image (and confirm)
      • highlight the line containing that point's information in the window above your image
      • find the corresponding point on the map
      • under Table>Raster, choose 'Select Control Point from Map'
      • click on the matching point (and confirm)
      • click the 'New' button in the Image Registration window
      • repeat the above steps in this list. Note: at least four points are recommended to achieve some degree of accuracy. Registering should include points chosen from the outside edges of the image. Ideally, 'error' column values shouldn't exceed 1 or 2, but higher values will work if precision isn't a priority.
    • Click 'OK"
    • Your raster image should appear on top of the map.

  • You can print directly from a map window or browser window using File>Print..., but for more control over the resulting page, use Window>New Layout Window
  • The layout window lets you select which windows to print, allows you to add text or graphics, resize elements, add/remove borders, etc.

Basics of Map modification
  • MapInfo stores information from separate tables in separate layers.
  • The Layer Control Button opens the window that lets you adjust these layers (the window can also be opened from Map>Layer Control). The example below illustrates how the layers can be adjusted.
  • Sample Layer Control window and resulting map (please maximize your browser window):

Changing the view, or zoom, of your map
  • These buttons for adjusting the view are foundin the main toolbar. It's helpful to spend a few minutes playing with and getting used to the various tools.
  • The Zoom-in tool magnifiesthe area you are looking at. Note that if you click a spot with the tool, that spot will be the center of the magnified image. You can also drag a rectangle with the tool, and the magnification of the window will adjust to frame that rectangle.
  • The Zoom-out tool yields awider view of the area. Again, the point clicked with the tool will be the center of the resulting image.
  • The Change View button (as well as Map>Change View) opens up a dialog box that allows you to specify the zoom in terms of units of distance and/or longitude and latitude.
  • The grabber tool lets youdrag the image around in the window. Try playing with it.
  • If you find yourself in a view you didn't want, Map>Previous View will take you back to the view you had before.
  • Map>View Entire Layer will let you see a table in its entirety (helpful since a table will sometimes open to a close-up view, and you won't know where you are).

Available Data(click link)

Useful MapInfo and GIS Resources

lm: June 28, 1999